Results 1 to 8 of 8

Thread: HSD DT coilover questions.

  1. #1
    Guest
    Join Date
    Nov 2006
    Location
    Bucks
    Posts
    985
    Rides
    0

    HSD DT coilover questions.

    Hi,ive got the DT range on an S14 Silvia.
    First it might be silly question, but which way round do the offset lower bushes go on the rears?
    Pics fitted?
    And also noticed that the botton bolt on rears doesn't go in too far, so not many threads holding them! Do they need new longer bolts??

  2. #2
    Guest
    Join Date
    Jun 2005
    Location
    Weston-Super-Mare
    Posts
    1,789
    Rides
    0
    offset away from the hub so the body doesn't hit, (basically spaced out, if I'm explaining that at all well!) I used the original bolts on my CS2's.

    Alex B

  3. #3
    Guest
    Join Date
    Nov 2006
    Location
    Bucks
    Posts
    985
    Rides
    0
    any pics at all?

  4. #4
    Guest
    Join Date
    Jun 2005
    Location
    Weston-Super-Mare
    Posts
    1,789
    Rides
    0
    No I can't find any.

    Alex B

  5. #5
    West Of Ireland Rep NismoNut's Avatar
    Join Date
    Feb 2010
    Location
    Mayo, Ireland
    Posts
    1,122
    Rides
    0
    The spacer goes towards the hub.
    I used the origional bolts, they dont have to thread in far as they arent under much pressure because the coilover is sitting on the hub.
    My S14.5 Rebuild Thread - clicky --
    http://www.sxoc.com/vbb/showthread.php?t=468362

  6. #6
    Flamespitter driftworks's Avatar
    Join Date
    Sep 2012
    Location
    Birmingham
    Posts
    128
    Rides
    0
    Quote Originally Posted by NismoNut View Post
    The spacer goes towards the hub.
    I used the origional bolts, they dont have to thread in far as they arent under much pressure because the coilover is sitting on the hub.
    what he said The spacer moves the lower mounting away from the hub. OEM bolts should be fine

  7. #7
    Guest
    Join Date
    Nov 2006
    Location
    Bucks
    Posts
    985
    Rides
    0
    Same coilovers still. How do you stop the front springs "twanging" when turning the steering? Ive set them up with a smidge of preload,but the springs still turn and make noise.
    More preload or less??

  8. #8
    West Of Ireland Rep NismoNut's Avatar
    Join Date
    Feb 2010
    Location
    Mayo, Ireland
    Posts
    1,122
    Rides
    0
    More preload i reckon
    My S14.5 Rebuild Thread - clicky --
    http://www.sxoc.com/vbb/showthread.php?t=468362

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •